依人网络官方网站

 找回密码
 注册帐号
查看: 3143|回复: 8

[编程问题] 找到丝路捡物CALL 写出来跳用不了 求大神指教

[复制链接]
发表于 2014-10-12 04:54:05 | 显示全部楼层 |阅读模式
.版本 2

.子程序 _按钮1_被单击
.局部变量 代码, 字节集

' push 3f0
' push 64
' mov esi,0131df5c
' mov esi,[esi]
' mov ecx,esi
' call 00858CF0

置代码 ({  })
Pushad ()
push (“3f0”)
push (“64”)
mov_ecx_dword_ptr (“131df5c”)
mov_ecx_esi ()
mov_ecx (“858CF0”)
call_ecx ()
popad ()
ret ()
代码 = _取代码 ()
调用汇编代码 (进程ID, 代码)

以上就是用清风模块 写的 注入器测试CALL可以 调用 写出来就不行了
 楼主| 发表于 2014-10-14 09:00:54 | 显示全部楼层
怎么没人回复 哎 大神哪里去了
回复 支持 反对

使用道具 举报

发表于 2014-10-14 22:39:49 | 显示全部楼层
对比代码,上下写法不一样
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-10-15 17:15:54 | 显示全部楼层
xiaomeimei 发表于 2014-10-14 22:39
对比代码,上下写法不一样

应该怎么写啊  改好多次都不行啊
回复 支持 反对

使用道具 举报

发表于 2014-10-16 08:40:07 | 显示全部楼层
mov_ecx_dword_ptr (“131df5c”)
mov_ecx_esi ()

esi 的值在哪?上面那句应该改为esi,也就是这样:
mov_esi_dword_ptr (“131df5c”)
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-10-16 10:40:43 | 显示全部楼层
clong 发表于 2014-10-16 08:40
mov_ecx_dword_ptr (“131df5c”)
mov_ecx_esi ()

.版本 2

置代码 ({  })
Pushad ()
push (“3f0”)
push (“64”)
mov_esi_dword_ptr (“131df5c”)
mov_ecx_esi ()
mov_ecx (“858CF0”)
call_ecx ()
popad ()
ret ()
代码 = _取代码 ()
调用汇编代码 (进程ID, 代码)

改了也不行 还是调用不了
回复 支持 反对

使用道具 举报

发表于 2014-10-16 10:53:20 | 显示全部楼层
2位高手能说明下这东西有什么用吗?在什么位置设置!
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-10-19 13:07:26 | 显示全部楼层
终于写出来了 换一个寄存器传递参数就行了
回复 支持 反对

使用道具 举报

发表于 2014-11-1 12:54:27 | 显示全部楼层
现在新丝路 怎么 开OD  附加 游戏退出
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册帐号

本版积分规则

QQ|小黑屋|手机版|Archiver|依人网络官方网站 ( 陕ICP备19025998号-1 )

GMT+8, 2022-1-26 23:13 , Processed in 0.044468 second(s), 21 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表